Website not responding

Incident Report for Lumanu

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 12:45 PDT

Monitoring

The front-end app appears to be responding now. We will continue to monitor this.
Posted Oct 20, 2025 - 11:27 PDT

Investigating

We are currently investigating an issue where the front end web application is not responding
Posted Oct 20, 2025 - 09:33 PDT
This incident affected: Lumau web application (Frontend application).