Degraded performance

Incident Report for Lumanu

Resolved

This issue has been resolved.
Posted Jun 08, 2026 - 13:30 PDT

Identified

We are currently experiencing degraded performance in our web application and API. We have identified the root cause and are deploying a temporary fix.
Posted Jun 08, 2026 - 12:37 PDT
This incident affected: Lumau web application (API server, Frontend application).